Archive for the ‘office 2007’ Tag

Missing officeLR.cab file during Office 2007 install

Had a stupid problem last two days with the installation of Office 2007 SBE on a brand new Dell laptop.  For a reason I won’t bore you with I had to rebuild from scratch the Vista install and then reinstall Office 2007 using the OEM disk I received from Dell.  The install would fail just after inputting the serial number just as the install process began, with the error message:

“Setup cannot find Office.en-us\OfficeLR.cab.  Browse to a valid installation source, and then click OK.”

This file does exist on the CD but pointing the installation to the correct location doesn’t work.

There are various solutions dotted round the internet: Google “OfficeLR.cab” -torrent, but none of them seem to do the trick for me.  These include:

  1. Copying the office CD to a local folder and installing from there – simply didn’t work for me;
  2. Cleaning the CD as it could be damaged – didn’t work and nor did the 5 other identical disks I have;
  3. Copying the files in the cab to the same folder (after following solution 1) – once again, no joy.

So the easy solution, which I wish I’d thought of hours ago, is to download the trial version of the relevant Office suite and install that – in my case found here http://trial.trymicrosoftoffice.com/trialukireland/product.aspx?sku=3082936 but I’m sure with a bit of googling for your product and country you’ll find the correct trial version.  Well, it’s nearly the easy solution, because when I tried to install that package I got this message: “The installation of this package failed”.  A typically helpful error message there from Microsoft.  A quick google later (http://support.microsoft.com/kb/926946) and I try doing this:

Self-Extractor_filename.exe /extract:”C:\Office2007″

Which doesn’t work either.  However, it does work on my own PC running XP SP3.  Once the files were extracted I copied them to the laptop and ran the Setup.exe and the trial installed correctly.  Then I used the original serial number to convert the trial to the full version and it worked!  Interestingly, but probably unsurprisingly, the trial version looks very similar once unpacked to the original CD and it has the officeLR.cab file.  Luckily no error message with the trial.

I did try the originally installer CD on my desktop PC and it ran fine.  So I don’t understand why this error occurs on Vista – any ideas?  Perhaps something to do with the Windows Installer on Vista?  Anybody?

[1] I include the “-torrent” in the search as there seems to be lots of torrents for that particular file – no idea why.